Serious acceleration issues in brand new Azera
  1. Welcome to Hyundai Azera Forum : Hyundai Azera Forums – General discussion forum for Hyundai Azera

    Welcome to Hyundai Azera Forum : Hyundai Azera Forums - a website dedicated to all things Hyundai Azera.

    You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, Join Hyundai Azera Forum : Hyundai Azera Forums today!
     
+ Reply to Thread
Results 1 to 7 of 7
  1. #1
    Junior Member
    Join Date
    Sep 2012
    Posts
    1

    Thumbs up Serious acceleration issues in brand new Azera

    Hello,

    Just joined. I wish I could say I was posting good news but unfortunately this car has a major acceleration issue. I have 630 miles on a 2012 Azera/tech package. Nice car I thought. I have almost been in 3 serious accidents as I cant get this car above 25 mph. I have turned it offf and restarted but it re appears. I had to flat bed it over to the dealer. This si my first hyundai and I am not a happy camper. I was told NOT to take the car back until its solved. I was also advised by legal coundel to get hyundai involved besides the dealer. I need to find the Illinois MFR rep. Anyone know how to do this??

    Sounds like quite the defect. Hope to have better news as I will give this one to Hyundai but I bought this car and did not lease it.

    AY

  2. Remove Advertisements
    Azera Forums
    Advertisements
     

  3. #2
    Super Moderator
    Join Date
    Dec 2006
    Location
    Nokomis, FL
    Posts
    953
    Welcome to the forum! It sounds like (based on my 2006 Azera) something has driven the processor into "limp-home mode," something the dealer can handle. From Answers.com:

    Your engine management and maybe even your transmission is controlled by the ECU. As you know, all computers crash, all software has bugs, and mechanical equipment fails. As such, many ECU units are fitted with a 'limp home mode'. When it detects that something semi-serious is wrong, it enters the limp mode, which means that the engine won't rev beyond a pre-programmed speed, you can't accelerate very fast, or you may indeed be speed-restricted to 40 mph or similar. The transmission may even stay in one or two gears. Bad? Well, no, not really: The alternative would be to either let you drive at regular speeds, with the danger of letting you trash your car (expensive repair, means happy repair people, but angry driver), or stopping you from going anywhere (expensive recovery and stranded on the side of the road means happy recovery company, but angry driver).

  4. #3
    Member
    Join Date
    Jun 2012
    Posts
    48
    Please keep us informed of the update. I also have a 2012 Azera and would like to know the issue.

  5. Remove Advertisements
    Azera Forums
    Advertisements
     

  6. #4
    Junior Member
    Join Date
    May 2013
    Posts
    15
    There's not been a car line that hasn't had problems. it just tuff when it's your car. as Gamie-ged said it's most likely a computer issue. as good as they are my macbook pro had a problem once..give Hyundai a chance to get it right. good luck & welcome i'm a newbie to.

  7. #5
    Junior Member
    Join Date
    Apr 2013
    Location
    Elgin, IL
    Posts
    16
    It looks like the OP was from last year. I wonder how he made out?
    2013 Hyundai Azera
    Tech Package
    Smoke Gray with Black Graphite Interior

  8. #6
    Junior Member
    Join Date
    Jun 2013
    Posts
    6
    I'm not sure this is related but, I've noticed that on 3 occassions my 1 week old 2013 runs very rough for about 1 minute after starting cold. It feels like the sound of a piston aircraft engine as it warms up , choppy - then after about a minute it runs normally. As I drove off the day, I noticed that during this "warm up " period the car chugged a bit as I was driving down my street. Any thoughts, thae car has 550 mile on it.

  9. #7
    Super Moderator
    Join Date
    Dec 2006
    Location
    Nokomis, FL
    Posts
    953
    That sounds like you may have a little water in your gasoline, add something like Valvoline water remover to your tank...

  10. Remove Advertisements
    Azera Forums
    Advertisements
     

+ Reply to Thread

Quick Reply Quick Reply

Not a Member Yet? Please Register Now.

Please select your insurance company (Optional)

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Similar Threads

  1. Replies: 9
    Latest Post: 05-09-2012, 06:20 PM
  2. acceleration hesitation?
    By AZERA 263HP in forum Engine and Transmission
    Replies: 13
    Latest Post: 11-16-2010, 03:16 PM
  3. high speed or low re shock issues?
    By rayeve in forum Suspensions & more
    Replies: 5
    Latest Post: 08-22-2009, 06:35 PM
  4. Acceleration/Kick Down
    By azzyfan in forum General Azera Talk
    Replies: 0
    Latest Post: 05-04-2008, 01:51 AM

Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBadvanced CMPS v4.1.2